const regex = /^(\S{2})\S*$|(?:^| *)(\S)\S* */gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S{2})\\S*$|(?:^| *)(\\S)\\S* *', 'gm')
const str = `Elon Musk
Elon musk
Elon`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);