# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s*<[^>]+>\s*)+/ /gm;t' <<< "<h1>Heading</h1>
<br>
<br />
<a href=\"#\">hyperlink</a>
<p></p>
<p>paragraph1</p>
<p>paragraph2</p>"