const regex = /(\s*<[^>]+>\s*)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s*<[^>]+>\\s*)+', 'gm')
const str = `<h1>Heading</h1>
<br>
<br />
<a href="#">hyperlink</a>
<p></p>
<p>paragraph1</p>
<p>paragraph2</p>`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);