// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\s*<[^>]+>\s*)+").unwrap();
let string = "<h1>Heading</h1>
<br>
<br />
<a href=\"#\">hyperlink</a>
<p></p>
<p>paragraph1</p>
<p>paragraph2</p>";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}