package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s*<[^>]+>\s*)+`)
var str = `<h1>Heading</h1>
<br>
<br />
<a href="#">hyperlink</a>
<p></p>
<p>paragraph1</p>
<p>paragraph2</p>`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}