using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s*<[^>]+>\s*)+";
string substitution = @" ";
string input = @"<h1>Heading</h1>
<br>
<br />
<a href=""#"">hyperlink</a>
<p></p>
<p>paragraph1</p>
<p>paragraph2</p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}