re = /(\s*<[^>]+>\s*)+/m
str = '<h1>Heading</h1>
<br>
<br />
<a href="#">hyperlink</a>
<p></p>
<p>paragraph1</p>
<p>paragraph2</p>'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result