#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(art\.range\.field\s*=\s*).*"
Local $sString = "art.range.field = 100" & @CRLF & _
"art.net.cap = 200" & @CRLF & _
"art.net.ht = 1000" & @CRLF & _
"art.net.dep = 8000"
Local $sSubst = "\g<1>500"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)