import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(art\\.range\\.field\\s*=\\s*).*";
final String string = "art.range.field = 100\n"
+ "art.net.cap = 200\n"
+ "art.net.ht = 1000\n"
+ "art.net.dep = 8000";
final String subst = "\\g<1>500";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}