# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(art\.range\.field\s*=\s*).*"
test_str = ("art.range.field = 100\n"
"art.net.cap = 200\n"
"art.net.ht = 1000\n"
"art.net.dep = 8000")
subst = "\\g<1>500"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.