const regex = new RegExp('^(art\\.range\\.field\\s*=\\s*).*', 'gm')
const str = `art.range.field = 100
art.net.cap = 200
art.net.ht = 1000
art.net.dep = 8000`;
const subst = `\g<1>500`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);