re = /^(art\.range\.field\s*=\s*).*/m
str = 'art.range.field = 100
art.net.cap = 200
art.net.ht = 1000
art.net.dep = 8000'
subst = '\\g<1>500'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result