using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(art\.range\.field\s*=\s*).*";
string substitution = @"\g<1>500";
string input = @"art.range.field = 100
art.net.cap = 200
art.net.ht = 1000
art.net.dep = 8000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}