use strict;
my $str = '5 Fragen an ... xyz';
my $regex = qr/\b5 Fragen an\h+\.+\h+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";