import re
regex = re.compile(r"\b5 Fragen an\h+\.+\h+", flags=re.MULTILINE)
test_str = "5 Fragen an ... xyz"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)