#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=^(?:(?:\d+:(?:\s00)*\n)*)(?:\d+:(?:\s00)*)\s+)\b(?!00)[0-9-afA-F]{2}\b"
Local $sString = "0000: 00 00 00" & @CRLF & _
"0001: 00 f8 00" & @CRLF & _
"0002: 11 00 22" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")