$re = '/(?<=^(?:(?:\d+:(?:\s00)*\n)*)(?:\d+:(?:\s00)*)\s+)\b(?!00)[0-9-afA-F]{2}\b/';
$str = '0000: 00 00 00
0001: 00 f8 00
0002: 11 00 22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);