using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^(?:(?:\d+:(?:\s00)*\n)*)(?:\d+:(?:\s00)*)\s+)\b(?!00)[0-9-afA-F]{2}\b";
string input = @"0000: 00 00 00
0001: 00 f8 00
0002: 11 00 22
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}