const regex = /(?<=^(?:(?:\d+:(?:\s00)*\n)*)(?:\d+:(?:\s00)*)\s+)\b(?!00)[0-9-afA-F]{2}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^(?:(?:\\d+:(?:\\s00)*\\n)*)(?:\\d+:(?:\\s00)*)\\s+)\\b(?!00)[0-9-afA-F]{2}\\b', 'g')
const str = `0000: 00 00 00
0001: 00 f8 00
0002: 11 00 22
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}