import re
regex = re.compile(r"(?<=^(?:(?:\d+:(?:\s00)*\n)*)(?:\d+:(?:\s00)*)\s+)\b(?!00)[0-9-afA-F]{2}\b")
test_str = ("0000: 00 00 00\n"
"0001: 00 f8 00\n"
"0002: 11 00 22\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")