#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<={|;)\s*@([\w_\$]*)\s*(\([\s'"\w_\$,#]*\))?\s*((public|private|protected)?\s+([\w_\$]*)\s*!?\s*:?\s*\w*\s*=?\s*([\w()\$]*))(?=}|;)"
Local $sString = "import { Inject, Injectable } from "../core/decorators";" & @CRLF & _
"" & @CRLF & _
"@Injectable()" & @CRLF & _
"class A {" & @CRLF & _
" public run() {" & @CRLF & _
" console.log('This is A');" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"class B {" & @CRLF & _
" @Inject('A') private a!: A;" & @CRLF & _
"" & @CRLF & _
" @Logger() class: number = 22;" & @CRLF & _
"" & @CRLF & _
" public constructor() {" & @CRLF & _
" this.a.run();" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"new B();" & @CRLF & _
"" & @CRLF & _
"console.log(B.toString());" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")