const regex = /(?<={|;)\s*@([\w_\$]*)\s*(\([\s'"\w_\$,#]*\))?\s*((public|private|protected)?\s+([\w_\$]*)\s*!?\s*:?\s*\w*\s*=?\s*([\w()\$]*))(?=}|;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<={|;)\\s*@([\\w_\\$]*)\\s*(\\([\\s\'"\\w_\\$,#]*\\))?\\s*((public|private|protected)?\\s+([\\w_\\$]*)\\s*!?\\s*:?\\s*\\w*\\s*=?\\s*([\\w()\\$]*))(?=}|;)', 'gm')
const str = `import { Inject, Injectable } from "../core/decorators";
@Injectable()
class A {
public run() {
console.log('This is A');
}
}
class B {
@Inject('A') private a!: A;
@Logger() class: number = 22;
public constructor() {
this.a.run();
}
}
new B();
console.log(B.toString());
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}