using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<={|;)\s*@([\w_\$]*)\s*(\([\s'""\w_\$,#]*\))?\s*((public|private|protected)?\s+([\w_\$]*)\s*!?\s*:?\s*\w*\s*=?\s*([\w()\$]*))(?=}|;)";
string input = @"import { Inject, Injectable } from ""../core/decorators"";
@Injectable()
class A {
public run() {
console.log('This is A');
}
}
class B {
@Inject('A') private a!: A;
@Logger() class: number = 22;
public constructor() {
this.a.run();
}
}
new B();
console.log(B.toString());
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}