re = /(?<={|;)\s*@([\w_\$]*)\s*(\([\s'"\w_\$,#]*\))?\s*((public|private|protected)?\s+([\w_\$]*)\s*!?\s*:?\s*\w*\s*=?\s*([\w()\$]*))(?=}|;)/m
str = 'import { Inject, Injectable } from "../core/decorators";
@Injectable()
class A {
public run() {
console.log(\'This is A\');
}
}
class B {
@Inject(\'A\') private a!: A;
@Logger() class: number = 22;
public constructor() {
this.a.run();
}
}
new B();
console.log(B.toString());
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end