import Foundation
let pattern = ##"(?<={|;)\s*@([\w_\$]*)\s*(\([\s'"\w_\$,#]*\))?\s*((public|private|protected)?\s+([\w_\$]*)\s*!?\s*:?\s*\w*\s*=?\s*([\w()\$]*))(?=}|;)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
import { Inject, Injectable } from "../core/decorators";
@Injectable()
class A {
public run() {
console.log('This is A');
}
}
class B {
@Inject('A') private a!: A;
@Logger() class: number = 22;
public constructor() {
this.a.run();
}
}
new B();
console.log(B.toString());
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)