#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<[^>\r\n]*>"
Local $sString = "<some chars and special chars maybe !@#$% but not gt and new lines and of course bounded by gt st>" & @CRLF & _
"" & @CRLF & _
"<some chars and special chars maybe !@#$% but not gt and new lines " & @CRLF & _
"" & @CRLF & _
"and of course bounded by gt st>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")