using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>\r\n]*>";
string input = @"<some chars and special chars maybe !@#$% but not gt and new lines and of course bounded by gt st>
<some chars and special chars maybe !@#$% but not gt and new lines
and of course bounded by gt st>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}