re = /<[^>\r\n]*>/m
str = '<some chars and special chars maybe !@#$% but not gt and new lines and of course bounded by gt st>
<some chars and special chars maybe !@#$% but not gt and new lines
and of course bounded by gt st>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end