// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<[^>\r\n]*>").unwrap();
let string = "<some chars and special chars maybe !@#$% but not gt and new lines and of course bounded by gt st>
<some chars and special chars maybe !@#$% but not gt and new lines
and of course bounded by gt st>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}