#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!\bbag\b).)*\bred\b.+?\bbag\b"
Local $sString = "choose balls if they are in red bag, or they are in green bag" & @CRLF & _
"choose balls if they are in green bag, or they are in red bag" & @CRLF & _
"choose balls if they are in red bag" & @CRLF & _
"choose balls if they are in green bag" & @CRLF & _
"bag red bag" & @CRLF & _
"red bag red" & @CRLF & _
"green bag red bag" & @CRLF & _
"red bags"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")