use strict;
my $str = 'choose balls if they are in red bag, or they are in green bag
choose balls if they are in green bag, or they are in red bag
choose balls if they are in red bag
choose balls if they are in green bag
bag red bag
red bag red
green bag red bag
red bags';
my $regex = qr/^(?:(?!\bbag\b).)*\bred\b.+?\bbag\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}