#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<.*?href="(.*?)"(?:[^"]*")+>(.*)<\/a>"
Local $sString = "<a data-popup-text="take me to <a href=\"http://www.google.com\">a search engine</a>" href="testing.html" data-id="1" data-popup-text="take me to <a href=\"http://www.google.com\">a search engine</a>">Testing</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")