package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<.*?href="(.*?)"(?:[^"]*")+>(.*)<\/a>`)
var str = `<a data-popup-text="take me to <a href=\"http://www.google.com\">a search engine</a>" href="testing.html" data-id="1" data-popup-text="take me to <a href=\"http://www.google.com\">a search engine</a>">Testing</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}