re = /<.*?href="(.*?)"(?:[^"]*")+>(.*)<\/a>/
str = '<a data-popup-text="take me to <a href=\\"http://www.google.com\\">a search engine</a>" href="testing.html" data-id="1" data-popup-text="take me to <a href=\\"http://www.google.com\\">a search engine</a>">Testing</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end