import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<.*?href=\"(.*?)\"(?:[^\"]*\")+>(.*)<\\/a>";
final String string = "<a data-popup-text=\"take me to <a href=\\\"http://www.google.com\\\">a search engine</a>\" href=\"testing.html\" data-id=\"1\" data-popup-text=\"take me to <a href=\\\"http://www.google.com\\\">a search engine</a>\">Testing</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}