using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<.*?href=""(.*?)""(?:[^""]*"")+>(.*)<\/a>";
string input = @"<a data-popup-text=""take me to <a href=\""http://www.google.com\"">a search engine</a>"" href=""testing.html"" data-id=""1"" data-popup-text=""take me to <a href=\""http://www.google.com\"">a search engine</a>"">Testing</a>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}