$re = '/<.*?href="(.*?)"(?:[^"]*")+>(.*)<\/a>/';
$str = '<a data-popup-text="take me to <a href=\\"http://www.google.com\\">a search engine</a>" href="testing.html" data-id="1" data-popup-text="take me to <a href=\\"http://www.google.com\\">a search engine</a>">Testing</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);