#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<InvoiceID>\d+)[ ]{0,1}INV[ ]{0,1}-[ ]{0,1}(?<ExtraInfo>.*)\.(?<Ext>\w+)$"
Local $sString = "I:\ARInvoices\COMPANY1\9801 INV - Check.pdf" & @CRLF & _
"I:\ARInvoices\COMPANY1\9801 INV-ExtraInfo.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")