// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<InvoiceID>\d+)[ ]{0,1}INV[ ]{0,1}-[ ]{0,1}(?<ExtraInfo>.*)\.(?<Ext>\w+)$").unwrap();
let string = "I:\\ARInvoices\\COMPANY1\\9801 INV - Check.pdf
I:\\ARInvoices\\COMPANY1\\9801 INV-ExtraInfo.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}