package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<InvoiceID>\d+)[ ]{0,1}INV[ ]{0,1}-[ ]{0,1}(?<ExtraInfo>.*)\.(?<Ext>\w+)$`)
var str = `I:\ARInvoices\COMPANY1\9801 INV - Check.pdf
I:\ARInvoices\COMPANY1\9801 INV-ExtraInfo.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}