import Foundation
let pattern = #"(?<InvoiceID>\d+)[ ]{0,1}INV[ ]{0,1}-[ ]{0,1}(?<ExtraInfo>.*)\.(?<Ext>\w+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I:\ARInvoices\COMPANY1\9801 INV - Check.pdf
I:\ARInvoices\COMPANY1\9801 INV-ExtraInfo.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)