$re = '/(?<InvoiceID>\d+)[ ]{0,1}INV[ ]{0,1}-[ ]{0,1}(?<ExtraInfo>.*)\.(?<Ext>\w+)$/m';
$str = 'I:\\ARInvoices\\COMPANY1\\9801 INV - Check.pdf
I:\\ARInvoices\\COMPANY1\\9801 INV-ExtraInfo.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);