re = /(?<InvoiceID>\d+)[ ]{0,1}INV[ ]{0,1}-[ ]{0,1}(?<ExtraInfo>.*)\.(?<Ext>\w+)$/m
str = 'I:\\ARInvoices\\COMPANY1\\9801 INV - Check.pdf
I:\\ARInvoices\\COMPANY1\\9801 INV-ExtraInfo.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end