#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\n$).*|^$"
Local $sString = "1.a food made from dried grains of maize that swell when they are heated " & @CRLF & _
"" & @CRLF & _
"2.a food made from dried grains of maize that swell when they are heated " & @CRLF & _
"" & @CRLF & _
" Thesaurus: rice, wheat and grain productshyponym types of food or drinkhypernym" & @CRLF & _
"3." & @CRLF & _
"" & @CRLF & _
"4.a food made from dried grains of maize that swell when they are heated"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")