import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\n$).*|^$";
final String string = "1.a food made from dried grains of maize that swell when they are heated \n\n"
+ "2.a food made from dried grains of maize that swell when they are heated \n\n"
+ " Thesaurus: rice, wheat and grain productshyponym types of food or drinkhypernym\n"
+ "3.\n\n"
+ "4.a food made from dried grains of maize that swell when they are heated";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}