import Foundation
let pattern = #"(?<=\n$).*|^$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.a food made from dried grains of maize that swell when they are heated
2.a food made from dried grains of maize that swell when they are heated
Thesaurus: rice, wheat and grain productshyponym types of food or drinkhypernym
3.
4.a food made from dried grains of maize that swell when they are heated
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)