re = /(?<=\n$).*|^$/m
str = '1.a food made from dried grains of maize that swell when they are heated
2.a food made from dried grains of maize that swell when they are heated
Thesaurus: rice, wheat and grain productshyponym types of food or drinkhypernym
3.
4.a food made from dried grains of maize that swell when they are heated'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end