const regex = /(?<=\n$).*|^$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\n$).*|^$', 'gm')
const str = `1.a food made from dried grains of maize that swell when they are heated
2.a food made from dried grains of maize that swell when they are heated
Thesaurus: rice, wheat and grain productshyponym types of food or drinkhypernym
3.
4.a food made from dried grains of maize that swell when they are heated`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}