use strict;
my $str = '1.a food made from dried grains of maize that swell when they are heated
2.a food made from dried grains of maize that swell when they are heated
Thesaurus: rice, wheat and grain productshyponym types of food or drinkhypernym
3.
4.a food made from dried grains of maize that swell when they are heated';
my $regex = qr/(?<=\n$).*|^$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}