#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^>]*A(?=<)"
Local $sString = "<table class="prod-fit-info-table">" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr class="tr -dark-grey">" & @CRLF & _
" <th class="td -outer">Make</th>" & @CRLF & _
" <th class="td -outer">Model</th>" & @CRLF & _
" <th class="td -outer">Year</th>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="tr -first">" & @CRLF & _
" <td class="td" rowspan="1">Make A</td>" & @CRLF & _
" <td class="td">Model A</td>" & @CRLF & _
" <td class="td">Year A</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="tr -grey -first">" & @CRLF & _
" <td class="td" rowspan="1">Make B</td>" & @CRLF & _
" <td class="td">Model B</td>" & @CRLF & _
" <td class="td">Year B</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="tr -first">" & @CRLF & _
" <td class="td" rowspan="1">Make C</td>" & @CRLF & _
" <td class="td">Model C</td>" & @CRLF & _
" <td class="td">Year C</td>" & @CRLF & _
" </tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")